Please enable JavaScript to view this site.

Navigation: Build an App > Add a Report to an App

Create a Workflow-Parameterized Report

Prev Top Next More

 

When you create a workflow-parameterized report, Designer creates both a report template and a workflow that accepts user input to generate the report. The following procedure creates workflow-parameterized report for the Buildings layer from a built-in template, and adds it as a menu item to the Result Details, Results List and Results Table menus.

You can customize the report template in VertiGIS Studio Report Designer or use the functionality provided by the template as is. You can also customize the workflow that generates the report in VertiGIS Studio Workflow Designer.

This option is not available for on-premise Reporting installations that are not installed in the default installation folder. If so, you must create the report within Report Designer instead.

To create a new workflow-parameterized report for a layer:

1.In Web Designer, in the Components panel, click Map, select the desired layer, and then click +Add Menu Item.

map-layer-add-menu-item

 A window appears that lets you select a command, workflow, report, or create a workflow or report.

2.Click the Reports tab.

3.At the bottom, click icon-plus-sign-in-circle-blue Create a new Report.

4.In the Select a Report Template menu, select the desired report template ending with - Workflow Parameterized. For example, Features(s) - 8.5 x 11 Landscape Table - Workflow Parameterized.

5.In the Title box, type a title for the report. For example, My Workflow-Parameterized Buildings Report.

6.By default, this is also the title of your menu item.

7.Click Create.

A report template named My Workflow-Parameterized Buildings Report is created, and a workflow named Run "My Workflow-Parameterized Buildings Report" is created. The workflow menu item appears in the results menus.

results-list-my-wf-parameterised-buildings-report

To edit the menu item, click the name of the menu item, for example Run "My Workflow-Parameterized Buildings Report". To edit the workflow that generates the report, additionally click Open in VertiGIS Studio Workflow. For information about editing workflows, see VertiGIS Studio Workflow Help.
 
To edit the report template, open VertiGIS Studio Report Designer, click File > My Reports, and click the title of your report. For information about editing reports, see VertiGIS Studio Reporting Help.

8.To save the app, click File > Save.

9.If you want the workflow and report to be available to other users, see Configure Sharing Permissions.

© 2024 VertiGIS North America Ltd. All Rights Reserved. | Privacy Center | Imprint
Documentation Version 5.29 (6252d320)